エントリー

ラズパイ4で「Raspberry Pi OS」が起動しない

先日,RetroPie4.7.1を試したが起動しなかった

状況としては

  • 電源ONで赤LEDが点灯,緑LEDが暫く点滅した後,いくら(5分位)待っても画面に何も表示されない
  • 電源の問題はなくmSDをアクセスしているのでIPLは動作している
  • mSDのパーティションを確認しても変化していないのでbootの途中で停止していると考えられる
  • 1年前にマニュアルインストールで構築したレトロパイmSDは起動する

少し色々と考えられることをやってみた結果

  • mSDカードの問題かと他のメーカーのカードでも試したが不可
  • config.txtを編集してHDMI出力を指定したが不可でセーフモードにしたが不可
  • 最新の「Raspberry Pi OS」(2021-01-11-raspios-buster-armhf-lite)で起動したが不可(ラズパイ用のOS名が「Raspbian」から「Raspberry Pi OS」になったようだ)

WS2021020501.png

そこで1年前のRaspbian(2020-02-05-raspbian-buster-lite)をセットアップして試してみたところ正常動作した

そしてアップグレード後も問題なく動作したので,去年の11月あたりから提供されているラズパイ4対応版の「Raspberry Pi OS」が動作しないのではないかということになる(当然ながら利用しているRetroPi4も動作しない)

$ cat /proc/version
Linux version 5.10.11-v7l+ (dom@buildbot) (arm-linux-gnueabihf-gcc-8 (Ubuntu/Linaro 8.4.0-3ubuntu1) 8.4.0, GNU ld (GNU Binutils for Ubuntu) 2.34) #1399 SMP Thu Jan 28 12:09:48 GMT 2021
$ cat /etc/debian_version
10.7
$

しかし,最新OSに関して特に問題があるという情報がネットで流れていないので,もしかすると拙者が持っているラズパイ4は何らかのハードが異なり起動しないのかもしれない

最近のOSバージョンではラズパイ4だけでなくラズパイ400も対応になっているので,boot時のハード切り分けに問題があるのではないかと考えてしまう

結局,アップグレードした「Raspberry Pi OS」を使いレトロパイをマニュアルインストールして最新版のエミュレータを動作させた

尚,音は問題なく出たので操作する必要はない

ページ移動

コメント

  • コメントはまだありません。

コメント登録

  • コメントを入力してください。
登録フォーム
名前
メールアドレス
URL
コメント
閲覧制限
投稿キー(スパム対策に、投稿キー を半角で入力してください。)

ユーティリティ

検索

エントリー検索フォーム
キーワード

新着コメント

Re:SDRplay社RSP1クローンを購入
2022/08/19 from 匿名希望
Re:SDRplay社RSP1クローンを購入
2022/08/16 from admin
Re:SDRplay社RSP1クローンを購入
2022/08/09 from 匿名希望
Re:SDRplay社RSP1クローンを購入
2022/08/08 from admin
Re:SDRplay社RSP1クローンを購入
2022/08/08 from 匿名希望

過去ログ

Feed